Составить программу которая находит наименьшее трехзначное число имеющее 10 делителей язык паскаль
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var i,k,n:integer;
for i:=100 to 999 do begin
k:=0;
for var j:=2 to i div 2 do
if i mod j =0 then inc(k);
if k=8 then break
end;
if k=8 then Writeln(i)
else Writeln(Нет искомых чисел)
end.
Результат:
112
Оцени ответ
