Составить программу в паскале которая проверяет наличие введенного слова в строке

Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write(Введите строку : );
    readln(s);
    write(Введите слово : );
    readln(a);
       if(pos(a, s) <> 0) then writeln(Слово ",a," в строке есть)
       else writeln(В строке такого слова нет);
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет




Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку