Принадлежит ли заданная точка заштрихованной фигуре? напишите программу , используя условный оператор, для паскаль абс

Var x,y:real;
    
    begin
    write(Введите координаты точки : );
    readln(x,y);
        if ((x>=-5)and (y>=-5) and(x<=0)and(y<=5))or ((x>=0) and (x<=5) and (sqrt(sqr(x)+sqr(y))<=5) and (y<=5) and (y>=0))  then writeln(Принадлежит)
       else writeln(Не принадлежит);
    end.

Тест №1
Введите координаты точки : 1 2
Принадлежит

Тест №2
Введите координаты точки : -3 -3
Принадлежит

Тест №3
Введите координаты точки : 3 -3
Не принадлежит





Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку