С++ Написать программу, которая проверяет, является ли квадратная матрица симметричной относительно главной диагонали.
Входные данные
В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) ( 1 ≤ N ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по N натуральных чисел, разделённых пробелами.
Выходные данные
Программа должна вывести слово YES, если матрица симметричная, и слово NO, если матрица несимметричная.
Помогите пожалуйста
//Dev C++ 4.9.9.2
#include
using namespace std;
int main(){
int n;
cin>>n;
cout<
ma=(int **)malloc(sizeof(int*)*n);
for (int i=0;i
for(int i=0;i
cout<
cout<<"NO";
cin.get();
cin.get();
return 0;}
cout<<"YES";
cin.get();
cin.get();
return 0;
}
Пример ввода:
4
1
2
3
4
2
1
2
3
3
2
1
4
4
3
4
1
Пример вывода:
YES
Оцени ответ
