Знатки информатики помогите.
Написать программу которая определяет содержит ли массив чисел число Х. Массив и Х - целые числа.

//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
begin
  var n := readinteger(Размер массива );
  //Для теста заполним массив сл. числами
  var a := arrrandom(n); a.Println;
  var x:=readinteger(Введите число Х);
  if x in a then writeln(массив содержит число , x)
  else writeln(массив не содержит число , x)
end.

Тест №1
Размер массива  10
96 14 36 84 55 1 74 99 72 20
Введите число Х 14
массив содержит число 14

Тест №2
Размер массива  10
59 9 8 98 75 34 52 63 62 17
Введите число Х 55
массив не содержит число 55


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку