1. Дан целочисленный массив из 30 элементов, которые могут принимать значения от 150 до 200 – рост учащихся выпускного класса. Напишите программу, которая выводит номера элементов с максимальными и минимальными значениями.
2. Дан целочисленный массив размерностью N (N –чётное число), заполненный случайными числами. Упорядочить по возрастанию первую половину массива, вторую половину оставить без изменений.

1.
const n=12; 
var
  a:array[1..n] of integer;
  i,max,imax,min,imin:integer;
begin
Randomize;
writeln(Исходный массив:);
for i:=1 to n do begin
  a[i]:=Random(51)+150;
  Write(a[i]:4)
end;
writeln;
max:=a[1]; imax:=1;
min:=a[1]; imin:=1;
for i:=2 to n do 
 begin
 if a[i]>max then begin max:=a[i]; imax:=i; end;
 if a[i] end; 
Writeln(max = a[,imax,] = ,max,,  min = a[,imin,] = ,min);
end.

Пример:
Исходный массив:
 170 165 194 186 165 161 174 172 177 191 158 181
max = a[3] = 194,  min = a[11] = 158

2.
const n=20; 
var
a:array[1..n] of integer;
i,j,c:integer;
begin
Randomize;
writeln(Исходный массив:);
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i], )
end;
Writeln;
for i:=1 to n div 2-1 do
  for j:=1 to n div 2-i do
    if a[j]>a[j+1] then
    begin c:=a[j]; a[j]:=a[j+1]; a[j+1]:=c end;
Writeln(Измененный массив:);
for i:=1 to n do Write(a[i], );
Writeln
end.

Пример:
Исходный массив:
16 3 1 18 10 -12 -23 19 -5 -5 0 10 13 14 17 14 6 22 25 -22 
Измененный массив:
-23 -12 -5 -5 1 3 10 16 18 19 0 10 13 14 17 14 6 22 25 -22

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку