Помогите с информатикой,пожалуйстааа
Нужно написать программу в Pascal ABC
Слова отделяются друг от друга одним пробелом, знаков препинания нет.
var
s,s1:string; l,p:integer; b:boolean;
begin
writeln(Введите строку:);
readln(s);
s1:=s+ ;
l:=pos( ,s1);
b:=true;
while p>0 do
begin
delete(s1,1,p);
p:=pos( ,s1);
if p>0 then b:=b and (l=p);
end;
if b then writeln(ДЛИНА);
end.
Пример:
Введите строку:
мама мыла раму
ДЛИНА
Оцени ответ
