составьте программу вычисления корней квадратного уравнения aх^2+вх+с=0 по данным значениям его коэффициентов.

var a, b, c, d, x1, x2 : real; 

begin 
write(a = ); readln(a); 
write(b = ); readln(b); 
write(c = ); readln(c); 
d := b*b + 4*a*c; 
if d=0 then 
begin 
x1 := b / (2 * a) 
writeln (x1:3:3); 
end 
else 
if d>0 then 
begin 
x1 := (- b + sqrt(d) / (2 * a); 
x2 := (- b - sqrt(d) / (2 * a); 
writeln (x1:3:3, , x2:3:3); 
end 
else 
writeln (Нет решения); 
end. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку