Напишите программу, которая в последовательности целых чисел определяет максимальное число. программа получает на вход целые числа, количество введенных чисел неизвестно. последовательность числа заканчивается числом 0. Количество чисел не превышает 1000. Введённые числа по модулю не превышает 30000. Программа должна вывести одно максимальное число.
Var max, n: integer;
begin
max := -30000;
read(n);
while n <> 0 do
begin
if n > max then max := n;
read(n);
end;
write(max);
end.
Оцени ответ
