Дан массив, состоящий из целых чисел. Напишите программу, которая подсчитает количество элементов массива, больших предыдущего (элемента с предыдущим номером).
Входные данные
Сначала задано число N — количество элементов в массиве (1N10000). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество элементов массива, больших предыдущего.

//PascalABC.NET 3.1 сборка 1200
begin
    var a := ReadArrInteger(ReadInteger());
    Println(a);
    
    var k := 0;
    for var i := Low(a) + 1 to High(a) do
        if a[i - 1] < a[i] then k += 1;
    
    writeln(k);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку