1) Числа Фибоначчи определяются формулами: f0=f1=1; fn=fn-1+fn-2 при n =2,3,… Т.е., это последовательность вида: 1,1,2,3,5,7,…
Составить программу определения n-ого члена Фибоначчи. Вычисления суммы всех чисел Фибоначчи, которые не превосходят 1000.
Надо написать программы на языке С++.
#include
using namespace std;
int main() {
int f0=1;
int f1=1;
int s=1;
int f=1;
while (f<=1000)
{
s=s+f;
f=f0+f1;
f0=f1;
f1=f;
}
cout << "s = " << s;
}
Результат:
s = 2583
Оцени ответ
