Помогите написать программу
В одномерном массиве, состоящем из 15 вещественных элементов (значения элементов массива задать случайными числами из интервала [-10;10]), вычислить произведение элементов массива, расположенных между максимальным и минимальным элементами. Сформировать из этих элементов новый массив.
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
var a:=ArrRandomReal(15,-10,10); a.Println; Writeln;
var m:=a.IndexMax;
var n:=a.IndexMin;
if m>n then (m,n):=(n,m);
var b:=a[m+1:n]; b.Println;
if b.Length>0 then Writeln(П=,b.Aggregate(1.0,(p,x)->p*x))
else Writeln(Нет элементов между минимумом и максимумом)
end.
Тестовое решение:
8.14904220316049 -7.97861530351388 6.22268662612079 -4.04729378132489 -1.70455696606289 2.5380224606665 9.52389909863653 6.96433030858838 3.31410986991325 4.31776128444716 -3.9021073439634 -1.69448156454343 -8.68306868648299 7.89553786529952 -0.403709360586344
6.96433030858838 3.31410986991325 4.31776128444716 -3.9021073439634 -1.69448156454343
П=658.932534926112
Оцени ответ
