Составьте программу,по которой компьютер десять раз запросит ввод любых чисел и в результате выведет среднее арифметическое значение введенных чисел (массив не использовать). Сделайте три варианта программы,используя операторы While,Repeat ,For.


//1
const
    n = 10;

var
    a, i, sum: integer;

begin
    sum := 0;
    i := 1;
    repeat
        Write(Введите число = );
        Readln(a);
        sum := sum + a;
        i := i + 1;
    until i > n;
    
    Writeln(Среднее арифметическое = , sum / n);
end.
//2
const
    n = 10;

var
    a, sum, i: integer;

begin
    sum := 0;
    i := 1;
    while i <= n do
    begin
        Write(Введите число = );
        Readln(a);
        sum := sum + a;
        i := i + 1;
    end;
    Writeln(Среднее арифметическое = , sum / n);
end.
//3
const
    n = 10;

var
    a, i, sum: integer;

begin
    sum := 0;
    for i := 1 To n Do
    begin
        Write(Введите число = );
        Readln(a);
        Sum := Sum + a;
    end;
    Writeln(Среднее арифметическое = , sum / n);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку