Программирование на C++
Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 <= x <= 30000).
Входные данные
Вводится натуральное число x.
Выходные данные
Выведите наименьший делитель числа x, отличный от 1.

#include
int main() {
int n;
std::cin >> n;
int i = 2;
while (n % i > 0) ++i;
std::cout << i;
return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку