Дано натуральное число. Верно ли, что сумма цифр данного числа больше А(А вводится с клавиатуры). Напишите программу Pascal, пожалуйста!
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
var n:=ReadInteger(Введите число);
var a:=ReadInteger(a=);
var s:=0;
while n>0 do begin s+=n mod 10; n:=n div 10 end;
if s>a then Write(Верно) else Write(Неверно);
Writeln(, что сумма цифр числа больше ,a)
end.
Тестовое решение
Введите число 46823
a= 24
Неверно, что сумма цифр числа больше 24
Оцени ответ
