Помогите решить с циклом repeat-until, дам лучший ответ!!!
1. Произведение первых нечетных натуральных чисел равно p. Сколько сомножителей взято.
2. Написать программу, вычисляющую сумму и среднее арифметическое последовательности чисел, которые вводятся с клавиатуры (ввод чисел оканчивается числом 0).

#include  using namespace std;                                                       double PI = 3.14159265;                                int main(){  double otvet = 10, kolvo = 0, sum = 0, srednee = 0;while ( otvet > 0 ){  cin >> otvet;  sum += otvet;  kolvo++; }  if( kolvo == 1 ) {  cout << 0 << " " << 0;  return 0; }  printf ("%.6f %.6f", sum, sum/(kolvo - 1));  return 0;}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку