Напишите программу, которая в последовательности натуральных чисел определяет максимальное, оканчивающееся на 1. Программа получает на вход кол-во чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 1.
Количество чисел не превышает 1000. Введённые числа не превышают 30000. Программа должна вывести одно число - максимальное число, оканчивающееся на 1.
Входны данные
3
11
21
31
Выходные данные
31

Var
    n, max, i, d: integer;

begin
    readln(n);
    max := 0;
    for i := 1 to n do
    begin
        readln(d);
        if (d mod 10 = 1) and ((max < d) or (max = 0)) then
            max := d;
    end;
    writeln(max);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку