Ниже записан алгоритм. Укажите наименьшее пятизначное число x, при вводе которого алгоритм печатает сначала 3, а потом 4.
var x, y, a, b: longint;
begin
a := 0;
b := 0;
readln(x);
while x > 0 do begin
y := x mod 10;
if y > 4 then a := a + 1;
if y < 6 then b := b + 1;
x := x div 10
end;
writeln(a);
writeln(b)
end.

Программа считает кол-во цифр больше 4-х и кол-во цифр меньше шести в твоем числе.
Первая цифра - это кол-во числе больше 4-х.
Вторая цифра - соответсвенно.

В итоге ответ получается: 10556

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку