Составьте программу вычисления среднего арифметического элементов массива А, состоящего из N элементов (N задается в блоке констант, элементы массива вводятся случайно и берутся из диапазона от -50 до 50).
паскаль

//Pascal ABC.NET v3.1 сборка 1219

Const
 n=15;

 Var
 ar:array[1..n] of integer;
 i:integer;
 sr:real;
begin
 randomize;
 writeln(Аrray:);
 for i:=1 to n do
  begin
   ar[i]:=random(-50,50);
   write(ar[i]:4);
     sr:=sr+ar[i];
  end;
 writeln;
 sr:=sr/n;
 writeln(Sr=,sr);
end.

Пример работы программы:
Аrray:
 -17  -7  31  49 -49   7  -6  17  30  37  25 -30  23 -40   7
Sr=5.13333333333333

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку