Ниже записан алгоритм. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 11.
var x, a, b: integer;
begin
readln(x);
a := 0; b := 1;
while x > 0 do begin
a := a+1;
b := b*(x mod 1000);
x := x div 1000;
end;
writeln(a); write(b);
end.

Программа... Вообщем непонятно что делает. Убирает последние три цифры у числа, затем Эти самые три цифры умножает на переменную "b", и так повторяется, пока это число не станет меньше 1000.

Вообщем... Ответ: 1011. Не парься

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку