ПОМОГИТЕ, ПОЖАЛУЙСТА)
Составить программу вычисления функции
( Sin(x), если x<=a;
z= ( Cos(x), если a( Tg(x), если x>=b.

var

a, b, x, s, c, t:real;


begin


writeln(Введите a);

readln(a);

writeln(Введите b);

readln(b);

writeln(Введите x);

readln(x);


if x<=a then

begin

s:=sin(x);

writeln (Синус равен , s);

end

else

writeln (Синус вычислить нельзя, так как равенство не равно , x, <=, a);


if (a

begin

c:=cos(x);

writeln (Косинус равен , c);

end

else

writeln (Косинус вычислить нельзя, так как равенство не равно , a, <, x, <, b);


if x>=b then

begin

t:=tan(x);

writeln (Косинус равен , t);

end

else

writeln (Косинус вычислить нельзя, так как равенство не равно , x, >=, b);


end.


Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку