Составьте программу замены нулевых элементов таблицы единицами
Контрольный пример n=5
Данные :(0,5,0,60,0)
Результат :(1,5,1,60,1)
Пожалуйста

Язык Pascal, работа на массиве. с заполнением с клавиатуры. Ты заполняешь 5 элементов ( через enter ), а он тебе выводит тоже самое, только с однерками вместо нулей.

Var x: array[1..5] of integer;
Var i,h:integer;
Begin
for i:= 1 to 5 do
Begin;
Readln(h);
if (h=0) then x[i]:=1 else x[i] = h;
end;
for i:=1 to 5 do
Begin;
Writeln(Элемент номер ,i, массива: ,x[i]);
end;
readln(x);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку