Ниже записан алгоритм. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 6.
var x, L, M: integer;
begin
readln(x);
L := 0;
M := 0;
while x > 0 do begin
M := M + 1;
if x mod 2 <> 0 then
L := L + 1;
x := x div 2;
end;
writeln(L);
writeln(M);
end.
Решение в приложенном файле.
Ответ 35.
Оцени ответ
