Найти количество трёхзначных чисел, кратных 5 и не превосходящих заданного числа N.
Входные данные:
в первой строке одно целое число N, (100 <= N <= 999)
Выходные данные:
одно число, являющееся ответом в соответствии с условием задачи.
Пример 1.
на входе:
128
на выходе:
6
Мне нужно точное решение,заранее спасибо))))

//Pascal ABC.NET v3.1 сборка 1219

begin
 var n:=readinteger();
 writeln(range(100,999).where(x -> x<=n).where(x -> x mod 5=0).Count);
end.

Пример ввода:
105
Пример вывода:
2

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку