Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить СРЕДНЮЮ ЗАРЕГИСТРИРОВАННУЮ скорость всех автомобилей. Если не менее двух автомобилей двигались со скоростью не больше 40 км/ч, выведите «YES», иначе выведите «N0».
Программа получает на вход число проехавших автомобилей N (1 =< N =< 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300.Программа должна сначала вывести среднюю скорость, затем «YES» или «N0».
Var sum,kol,bol,n,x,i:integer;beginread(n);for i:=1 to n do begin read(x); if x<=40 then inc(bol); inc(kol); inc(sum,x); end;writeln(sum/kol);if bol>1 then writeln(YES) else writeln(NO);end.
Оцени ответ
