Дано N (N больше 0) Натуральных чисел. написать программу, определяющую наибольшее среди них. Число N вводится перед всеми остальными числами
var n,i,max:integer;
a:array[1..10000] of integer;
begin
randomize;
writeln(Введите кол.натур. чисел: );
read(n);
for i:=1 to n do begin
a[i]:= random(n*n);
write(a[i], );
//read(a[i]); //Если нужен ввод с клавиатуры
end;
writeln;
max:=a[1];
for i:=1 to n do begin
if a[i]>= max then
begin
max:=a[i];
end;
end;
writeln(Наибольшее число:, max);
end.
Оцени ответ
