Пожалуйста помогите!
На надо решать все сразу. Пожалуйста хотя бы одну.
Очень надо!
Написать программу
На языке Паскаль
1. Вывести все трёхзначные числа на экран, через пробел
2. Вывести на экран 10 раз своё имя
3. Найти произведение цифр натурального числа
4. Найти наибольшую цифру в натуральном числе
1.
program tridigit;
var
n:integer;
begin
n := 100;
repeat
write (n, );
n := n + 1;
until n > 999
end.
2.
program name10;
var
name:String;
i:integer;
begin
name := Алексей;
for i := 1 to 10 do
writeln(name);
end.
3.
program nat_mult;
var
sum,number: integer;
begin
sum := 1;
write (введите натуральное число: );
read(number);
while number > 0 do
begin
sum := sum * (number mod 10);
number := (number div 10);
end;
writeln(Произведение цифр данного числа: , sum);
end.
4.
program mx_number;
var
a,mx:integer;
begin
repeat
write(Введите натуральное число: );
readln(a);
until a>0;
mx:=0;
while a>0 do
begin
if a mod 10>mx then
mx:=a mod 10;
a:=a div 10;
end;
write(Наибольшая цифра: ,mx);
end.
