Помогите,пожалуйста!информатика,10 класс,Паскаль
1)Написать программу.Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:сумма десятков первого и второго числа и сумма единиц первого и второго числа.
2)Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:произведение десятков первого числа и единиц второго числа;произведение единиц первого числа и десятков второго.
3)Вводятся два двухзначных целых числа.Подсчитать и вывести два числа:произведение десятков первого числа и единиц второго числа;сумма единиц первого числа и десятков второго числа.

Первая программа.

Program d_and_e;

Var
   a,b,sum_d,sum_e:integer;

Begin
  WriteLn(введите первое число: );
  ReadLn(a);
  WriteLn(введите второеое число: );
  ReadLn(b);
  sum_d:=(a div 10) + (b div 10);
  sum_e:=(a mod 10) + (b mod 10);
  WriteLn(сумма десятков чисел: , sum_d);
  WriteLn(сумма единиц чисел: , sum_e);
end.

Вторая программа.

Program d_and_e;

Var
   a,b,mult_d1_e2,mult_e1_d2:integer;

Begin
  WriteLn(введите первое число: );
  ReadLn(a);
  WriteLn(введите второе число: );
  ReadLn(b);
  mult_d1_e2:=(a div 10) * (b mod 10);
  mult_e1_d2:=(a mod 10) * (b div 10);
  WriteLn(произведение десятков 1-го и единиц 2-го числа: , mult_d1_e2);
  WriteLn(произведение единиц 1-го и десятков 2-го числа: , mult_e1_d2);
end.

Третья программа.

Program d_and_e;

Var
   a,b,mult_d1_e2,sum_e1_d2:integer;

Begin
  WriteLn(введите первое число: );
  ReadLn(a);
  WriteLn(введите второе число: );
  ReadLn(b);
  mult_d1_e2:=(a div 10) * (b mod 10);
  sum_e1_d2:=(a mod 10) + (b div 10);
  WriteLn(произведение десятков 1-го и единиц 2-го числа: , mult_d1_e2);
  WriteLn(сумма единиц 1-го и десятков 2-го числа: , sum_e1_d2);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку