Дано N-значное натуральное число X.
Ваша задача - переставляя цифры числа X, получить наименьшее возможное N-значное число Y.
Напишите программу для решение данной задачи



#include #include #include
using namespace std;
int n;string x;
int main(){    cin >> n >> x;        sort(x.begin(), x.end());        int first_not_zero = -1;    for (int i = 0; i < n; ++i)    {        if(x[i] != 0)        {            first_not_zero = i;            break;        }    }        if(first_not_zero != -1)        swap(x[0], x[first_not_zero]);        cout << x << endl;        return 0;}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку