Напишите программу, которая находит минимальный и максимальный элементы из элементов матрицы с четными положительными значениями и их индексы. учтите, что таких элементов в матрице может и не быть

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  var m:=ReadInteger(Число строк=);
  var n:=ReadInteger(Число стролбцов=);
  var a:=MatrixRandom(m,n,-99,99);
  var imax:=-1; var jmax:=0;
  var imin:=0; var jmin:=0;
  var min:=100; var max:=-100; // больше большего, меньше меньшего
  for var i:=0 to m-1 do begin
    for var j:=0 to n-1 do begin
      Write(a[i,j]:4);
      if (a[i,j]>0) and (a[i,j] mod 2=0) then begin
        if a[i,j]        if a[i,j]>max then begin imax:=i; jmax:=j; max:=a[i,j] end
        end
      end;
    Writeln
    end;
  if imax<>-1 then begin
    Writeln(Минимальный четный положительный элемент A[,
        imin+1,,,jmin+1,]=,a[imin,jmin]);
    Writeln(Максимальный четный положительный элемент A[,
      imax+1,,,jmax+1,]=,a[imax,jmax])
    end
  else
    Writeln(В массиве нет положительных четных элементов)
end.

Тестовое решение
Число строк= 5
Число стролбцов= 8
 -59  98  55 -92 -98  68   5 -82
  63  49  41   7  51  22  55  -4
 -78  42 -35 -60  -6 -15 -34 -28
 -14  55 -44  22  74 -50 -98  85
  50   2  65  39 -47 -59  -7 -87
Минимальный четный положительный элемент A[5,2]=2
Максимальный четный положительный элемент A[1,2]=98

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку