Напишите программу,которая в последовательности натуральных чисел определяет наибольшее число ,кратное 3и оканчивающееся на 6.Программа получает на вход количество чисел в последовательности ,а затем сами числа.В последовательности всегда имеется число кратное 3 и оканчивающееся на 6. Количество чисел не превышает 1000.Введенные числа не превышают 30000. Программа должна вывести одно число :наибольшее число,кратное 3 и оканчивающееся на 6.Входные данные:5,18,126,165,36,135.Выходные данные:126
Var max,n,x:integer;
begin
writeln(Введите количество цифр);
read(n);
max:=0;
repeat
writeln(Введите число. (Осталось ввести ,n, ));
readln(x);
if (x mod 3=0) and (x mod 10=6) and (abs(x)>max) then max:=x;
n:=n-1;
until n=0;
writeln(Максимальное число, кратное 3-м и заканчивающееся на 6 = ,max);
end.
Оцени ответ
