Задана последовательность неотрицательных целых чисел. Требуется определить длину последовательности, завершающуюся первым встретившимся нолем (число 0 не входит в последовательность).
Входные данные
Входной файл INPUT.TXT содержит последовательность неотрицательных целых чисел, не превышающих значения 100. Гарантируется, что во входных данных не более 100 чисел и среди них есть хотя бы одно число 0.
Выходные данные
В выходной файл OUTPUT.TXT выведите целое число – длину последовательности. Пожалуйста решите, на C++ или на Pascal
Program arr_length;
const
IN_FILENAME = INPUT.txt;
OUT_FILENAME = OUTPUT.txt;
var
fileIn,fileOut: TextFile;
s,t: string;
begin
writeln(Загружаю входные данные...);
t := ;
AssignFile(fileIn, IN_FILENAME);
AssignFile(fileOut, OUT_FILENAME);
reset(fileIn);
while not eof(fileIn) do
begin
readln(fileIn, s);
if (s = 0) then
break
else
t := t + s;
end;
CloseFile(fileIn);
rewrite(fileOut);
writeln(fileOut, Length(t));
CloseFile(fileOut);
end.
Оцени ответ
