
Написать программу поиска номера элемента массива, принадлежащего заданному промежутку [1, 5], используя линейный поиск.Решить на Pascal ABC.
Пример:Линейный поиск элементов массива:
procedure poisk (z:omas; x:integer);
var i,p:byte;
begin
for i:=1 to n do
begin
if z[i]=x then p:=i;
end;
end;

Const n = 5;
var
i, p, x:byte;
z: array[1..n] of byte;
begin
readln(x);
for i:=1 to n do
begin
readln(z[i]);
if z[i]=x then p:=i;
end;
writeln(p);
end.
Оцени ответ