Напишите программу, вычисляющую значение функции
y={ -1 при х<0
y={0 при х=0
y={1 при х<0

Это определение стандартной неэлементарной кусочно-постоянной математической функции sgn(x) - сигнум От латинского signum - знак).
В языке Паскаль эта функция уже определена.

// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
// Также проверено в WDE: http://pascalabc.net/WDE
begin
  Writeln(y=,Sign(ReadReal(x=)))
end.

Тестовое решение
x= 4.564
y=1

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку
×