
Составьте программу ,увеличивающую четные элементы линейного массива A[1..N] на 1

Var
i,n:integer;
a:array [1..1000] of integer;
Begin
Read(n);
For i:=1 to n do
Read(a[i]); //вводим элементы массива
For i:=1 to n do begin
If a[i] mod 2 = 0 then inc(a[i]); //прибавляем 1 к четным элементам
Write(a[i], );
End;
End.
Оцени ответ