Дан массив из 20 натуральных чисел. Составить программу суммы элементов, кратных данному числу d .

Const 
n=20; 
var a:array[1..n] of integer; 
var i,d,s:integer; 
begin 
s:=0; 
writeln(Введите число d); 
readln(d); 
writeln(Введите массив); 
for i:=1 to n do begin 
read(a[i]); 
if a[i] mod d = 0 then s:=s+a[i]; 
end; 
writeln(s); 
end. 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку