составить программу в паскале! пожалуйста!!! СРОЧНО! 9 класс! Написать программу, которая на ввод времени суток выводит соответствующее пожелание доброго утра, доброго дня, доброго вечера или спокойной ночи.
var
time: 0..23;
begin
writeln(Введите текущее время в часах);
readln(time);
if time in [0..6] then writeln(Спокойной ночи!);
if time in [7..12] then writeln(Доброго утра!);
if time in [13..18] then writeln(Доброго дня!);
if time in [19..23] then writeln(Доброго вечера!);
end.
Пояснение: в этой программе используются множества. Если время в часах входит в множество чисел, указанных в квадратных скобках, то программа пишет соответствующее сообщение. Например: if time in [0..6] означает: если введенное время входит в промежуток от 0 до 6.
