Решите 2 задачи в Паскале! Плииз!
1) Вывести на экран нарутальные числа от 1 до 100, которые при делении на 6 дают в остатке 4, и их колличество. Конец программы:
SumChis :=0;
for i:1 to 100
if i mod 6 = 4 then
begin
writeln (i);
SumChis :=SumChis +1;
end.
Написать надо начало программы!
2) Написать программу, которая выводит натуральные числа до 10 000 включительно, которые при делении на 17 дают остаток 11 или B
1)
var sumchis, i:integer;
begin
for i:=1 to 100 do begin
if i mod 6 =4 then
begin
writeln(i);
sumchis:=sumchis+1;
end;
end;
writeln(Колличество чисел, sumchis);
end.
2)
var sumchis, i:integer;
begin
for i:=1 to 10000 do begin
if i mod 17 =11 then
begin
writeln(i);
sumchis:=sumchis+1;
end;
end;
writeln(Колличество чисел, sumchis);
end.
Как сделать чтобы остаток равнялся B - не знаю, так как программа начинает считывать её как за переменную, если только B определить как переменную и в неё внести значение какое-то.
