Составить программу в паскале:
Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие результаты.:
· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.
· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.
· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму
· Иначе, выведите удвоенные значения этих чисел
var
a,b,c,d:real;
begin
readln (a,b,c,d);
if ((a<0) and (b=2*c)) and ((a*b*c*d)>a+c+c+d)
then
begin
writeln (Среднее арифметическое: ,(a+b+c+d)/4);
writeln (Произведение: , a*b*c*d);
writeln (сумма:,a+b+c+d)
end
else
if (a<0) and (b=2*c)
then writeln (Среднее арифметическое: ,(a+b+c+d)/4)
else
if ((a*b*c*d)>(a+c+c+d))then
begin
writeln (Произведение: , a*b*c*d);
writeln (сумма:,a+b+c+d)
end
else writeln (2*a, ,2*b, ,2*c, ,2*d);
end.
