1. Написать программу, которая подсчитывает количество четных чисел в массиве целых чисел. Количество элементов массива равно N.

Решение на языке C:

 

#include

int func(int *array, int n)
{
  int result = 0;
  for (int i = 0; i < n; i++) {
    if (array[i] % 2 == 0) {
      result++;
    }
  }
  return result;
}

int main(int argc, char *argv)
{
  int array[] = {1, 2 , 3 , 4 , 5 , 6, 7, 46};
  printf("%d", func(array, 8));
  return 0;
}

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку