Даны три числа x,y,z.Если их значения упорядочены по убыванию, то удвоить их; в противном случае заменить значение каждой переменной на противоположное. Помогите пожалуйста составить программу Paskal.)))))))))))))
Program Zamena;
Uses Crt;
var x,y,z:real;
b:boolean;
begin
clrscr;
write(Введите x:);
readln(x);
write(Введите y:);
readln(y);
write(Введите z:);
readln(z);
b:=((x>y) and (y>z) and (z
if (b=true) then
begin
x:=2*x;
y:=2*y;
z:=2*z;
end
else
begin
x:=-x;
y:=-y;
z:=-z;
end;
writeln(x =,x);
writeln(y =,y);
writeln(z =,z);
readkey;
end.
Оцени ответ
