Помогите решить срочно:

РЕШИТЕ СКОЛЬКО СМОЖЕТЕ,ЗАРАНЕЕ СПАСИБО!!!!

1)Дано натуральное трехзначное число . Определить число, полученное перестановкой разрядов десятков и единиц исходного числа.

2)Дано натуральное трехзначное число . Определить число, полученное перестановкой разрядов десятков и сотен исходного числа.

3)Дано натуральное трехзначное число . Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч)

4)Дано натуральное четырехзначное число . Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.

5)Дано натуральное четырехзначное число . Определить число, полученное перестановкой разрядов десятков и единиц исходного числа.

6)Дано натуральное четырехзначное число . Определить число, полученное перестановкой разрядов десятков и сотен исходного числа.

1)

var

  a: 100..999;

  a1, a2, a3: 0..9;  //а1 - сотни, а2 - десятки, а3 - единицы

 

begin

  writeln(Введите натуральное трехзначное число);

  readln(a);

  a1:= a div 100;

  a2:= (a mod 100) div 10;

  a3:= a mod 10;

  writeln(Полученное число:  , a1, a3, a2);

end.

2)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin

  

 writeln(Введите натуральное трехзначное число);

  readln(a);

  a1:= a div 100;

  a2:= (a mod 100) div 10;

  a3:= a mod 10;

  writeln(Полученное число:  , a2, a1, a3);

end.

3)

var

  a: 100..999;

  a1, a2, a3: 0..9;

 

begin 

 writeln(Введите натуральное трехзначное число);

  readln(a);

  a1:= a div 100;

  a2:= (a mod 100) div 10;

  a3:= a mod 10;

  writeln(Полученное число:  , a3, a1, a2, a3);

end.

4)

var

  a: 1000..9999;

  a1, a2, a3, a4: 0..9;

 

begin

  writeln(Введите натуральное четырехзначное число);

  readln(a);

  a1:= a div 1000;  //тысячи

  a2:= (a mod 1000) div 100;  //сотни

  a3:= (a mod 100) div 10;  //десятки

  a4:= a mod 10;  //единицы

  writeln(Полученное число:  , a4, a3, a2, a1);

end.

Все остальное делается наподобие этого: просто в writeln меняешь местами цифры и все.

  

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку