Написать программу на паскале
Если данное число х меньше нуля, то Z присвоить значение большего из 2 чисел х и у, иначе Z присвойте значение полсуммы этих чисел.

  Program Z;

Uses Crt;

var x,y,z:real;

begin

    clrscr;

    write(Введите х: );

    readln(x);

    write(Введите y: );

    readln(y);

    if (x<0)  and (x>y) then z:=x;

    if (x<0)   and (x

 

    if (x>=0) then z:=(x+y)/2;

    writeln(z=,z);

   readkey;

 

end. 

 

 

 

 

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку