написать программу на Паскале: А) Условие задачи №1: если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «Ошибка ввода».
var
i,x,n:integer;
s1,s2,s3:string;
begin
write(Введите число: );
readln(x); if (x >999) or (x<10) then write(Ошибка ввода!);
if (x<999) and (x>99) then begin
str(x,s1);
delete(s1,2,1);
write(s1);
end;
if (x<100) and (x>9) then begin
n:= x div 10 *2;
x:=x mod 10 *2;
str(n,s1);
str(x,s2);
s3:=s1+s2;
write(s3);
end;
end.
Оцени ответ
