написать программу на Паскале:
"если введенное целое число является трехзначным, то удалить из него среднюю цифру; если число двухзначное, то удвоить крайние цифры; иначе – выдать сообщение «Ошибка ввода»."
program z1;
uses crt;
var n:integer;
begin
writeln(вв число);
readln(n);
if n>999 then writeln(ошибка ввода) else
if n>100 then writeln((n div 100)*10+n mod 10 ) else
writeln((((n div 10)*2)*10)+((n mod 10)*2));
end.
Оцени ответ
