На языке программирования Паскаль составить программу перевода из десятичной системы счисления в систему счисления с основанием Х, где Х - целое число, определяемое по такому правилу: если 2-я буква фамилии учащегося находится в интервале от А до Д, то Х = 9; если 2-я буква фамилии учащегося находится в интервале от Е до К, то Х = 8; если 2-я буква фамилии учащегося находится в интервале от Л до Р, то Х = 7; если 2-я буква фамилии учащегося находится в интервале от С до Ц, то Х = 6; если 2-я буква фамилии учащегося находится в интервале от Ч до Я, то Х = 5.

var
a: string;
x: integer;
begin
write(Введите слово: ); readln(a);
length(a);
if (a[2]=а) or (a[2]=б) or (a[2]=в) or (a[2]=г) or (a[2]=д) then x:=9;
if (a[2]=е) or (a[2]=ж) or (a[2]=з) or (a[2]=и) or (a[2]=й) or (a[2]=к) then x:=8;
if (a[2]=л) or (a[2]=м) or (a[2]=н) or (a[2]=о) or (a[2]=п) or (a[2]=р) then x:=7;
if (a[2]=с) or (a[2]=т) or (a[2]=у) or (a[2]=ф) or (a[2]=х) or (a[2]=ц) then x:=6;
if (a[2]=ч) or (a[2]=ш) or (a[2]=щ) or (a[2]=ы) or (a[2]=ъ) or (a[2]=ь) or (a[2]=э) or (a[2]=ю) or (a[2]=я) then x:=5;
writeln(Перевод: , x);
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку