Найти все натуральные числа а, b и с из интервала от 1 до 20, для которых выполняется равенство: a^2+b^2=c^2 (составить программу на языке программирования)

var a,b,c:integer;
begin
for a:= 1 to 20 do
for b:= 1 to 20 do
for c:= 1 to 20 do
begin
if a*a+b*b=c*c then
writeln(a:4,b:4,c:4);
end;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку