Составьте программу вычисления среднего арифметического отрицательных элементов массива. заранее спасибо!!!

uses CRT;
cоnst n = 15;
var b: array [1..n] of Integer; s,p,k: Integer;
begin
clrscr;
for k:=1 to n do readln(b[k]);
s:=0;
p:=0;
for k:=1 to n do if b[k] < 0 then
begin
s:=s+b[k];
p:=p+1;
end;
writeln(Среднее арифм. равно: , (s/p):9:4);
readkey;
end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку