Каждая бактерия делится на 2 в течении 1 минуты.в начальный момент(t=0) имеет 1 бактерию.Переислите сколько их встанет через 15 минут?Нужно составить программу
program xxx;
VAR:..
и т.д.
Помогите пожалуйста,пропустила эту тему а завтра контрольная:с
Как то так, но может быть неправельно.
1 var
2 Bakteriya, Vremya: integer;
3 i: byte;
4 begin
5 Bakteriya:=1; Vremya:=15;
6 i:=2;
7 while i <= Vremya do
8 begin
9 Vremya:=Vremya-1;
10 Bakteriya:=Bakteriya*2;
11 end;
12 writeln(Кол-во бактерий через 15 минут: , Bakteriya);
13 end.
.
Оцени ответ
