Дан двумерный массив размерностью n*m. Заменить все отрицательные элементы на противоположные.(помогите составить программу для паскаля).

const NN=50;
var
a:array [1..NN,1..NN] of integer;
i,j,m,n:integer;
begin
  write(Введите n: );
  readln(n);
  write(Введите m: );
  readln(m);
  for i:= 1 to n do
    for j:= 1 to m do
      readln(a[i,j]);
 for i:= 1 to n do
    for j:= 1 to m do
      if a[i,j]<0 then a[i,j]:=abs(a[i,j]);
 for i:= 1 to n do
 begin
    for j:= 1 to m do
      write(a[i,j], );
    writeln;
 end;
 end.

Оцени ответ
Подпишись на наш канал в телеграм. Там мы даём ещё больше полезной информации для школьников!

Загрузить картинку